Forum pour réunir les administrateurs de serveur L2
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 probleme avec la bestiole

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
decarvk



Nombre de messages : 242
Age : 27
Localisation : en france
Date d'inscription : 06/07/2008

MessageSujet: probleme avec la bestiole   Jeu 18 Sep 2008, 18:03

salutation a touts et a toutes,

voila je vous compte un des nombreux essai pour réinstaller ma bestiole (usine a gaz) d'eclipse:


j'ai commencer par télecharger sur le site officiel la v3.4 (ils ont pas de retro liens).
une fois cela fait je dezip je me retrouve avec mon beau dossier eclipse, tout fier je le démarre presser d'installer mes plugins, je commence par subclipse, il passe niquel rien a redire.

je m'attelle alors a maven et la les erreurs commence:

An error occurred during provisioning.
Cannot connect to keystore.
JKS

cette erreur surviens quand la barre arrive a 100% ^^'' (pas de chance, hein?)

donc je me suis dit google est mon amis top départ petite recherche:

maven plugin eclipse 3.4

la je trouve des tutos don celui du site de maven, qui dans les pre requis parle de mylyn je vais donc installer mylyn suivant le tuto, et la boom erreur il trouve rien, (source du site de eclipse).

je m'en remet donc a des gens qui aurait peut être une solution ou un eclipse 3.1 a partager ^^''

merci par avance.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://nemerian.apdvm.asso.fr
supermamie



Nombre de messages : 46
Date d'inscription : 11/09/2008

MessageSujet: Re: probleme avec la bestiole   Jeu 18 Sep 2008, 20:09

La solution que je te propose c'est celle que j'utilise...
Je n'ai jamais utilisé maven dans eclipse mais toujours en ligne de commande.

Bon je n'ai rien fait de plus que compiler avec donc c'est assez simple, pour rajouter des dépendances par contre, la je ne sais pas :/
(mais ça ne se fait pas tous les jours je pense)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Grimly



Nombre de messages : 601
Date d'inscription : 30/08/2007

MessageSujet: Re: probleme avec la bestiole   Jeu 18 Sep 2008, 22:45

maven n'a jamais (du moins avec moi) fonctionné sur Eclipse correctement. La seule chose que ça a apporté, c'est qu'il a ferme enfin sa grande gueule (et je le lui rend bien quelques fois) à cause des librairies qu'il ne connais pas si on est sous L2JFree.

Pour l'installer, le lien qui est donné sur le tuto ne marche plus mais a changé pour qqch comme ça : "http://m2eclipse.sonatype.org/update/"

Après c'est de l'adaptation au changement de version, hésitez pas à tout réinstaller, les serveurs universitaires (plupart des mirroirs d'eclipse) sont là pour vous faire downloader comme des fous.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
decarvk



Nombre de messages : 242
Age : 27
Localisation : en france
Date d'inscription : 06/07/2008

MessageSujet: Re: probleme avec la bestiole   Mar 23 Sep 2008, 16:20

voila j'ai installer maven a part pour compiler en linge de comande ( sa me derange pas les ligne de comande l'habitude avec nux) mais une erreur survien lors de la compile:


[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Cannot get the revision information from the scm repository :
svn: This client is too old to work with working copy '/home/guss/compile/l2jfree-core'; please get a newer Subversion client

[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 3 seconds
[INFO] Finished at: Tue Sep 23 15:13:23 CEST 2008
[INFO] Final Memory: 9M/76M
[INFO] ------------------------------------------------

il me dit que mon subversion est pas a jour mais ya un petit hic c'est le dernier dispo des depots (debian/lenny(testing))

est ce que je devrai downgrader mon maven?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://nemerian.apdvm.asso.fr
Hizin



Nombre de messages : 501
Age : 27
Localisation : Le Mans, Sarthe
Date d'inscription : 08/04/2007

MessageSujet: Re: probleme avec la bestiole   Mar 23 Sep 2008, 18:46

Pour Eclipse, tu as une version avec Mylyn directement intégrée dedans si tu le désirs vraiment.

Après, je ne suis pas spécialiste en maven, mais si tu as cette erreur alors que c'est la dernière version, oui, prend la précédente.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
decarvk



Nombre de messages : 242
Age : 27
Localisation : en france
Date d'inscription : 06/07/2008

MessageSujet: Re: probleme avec la bestiole   Mar 23 Sep 2008, 18:54

oui j'ai desuite pris la 2.0.8 mais le probleme perciste je vais downgrader les version 1 par 1 ^^
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://nemerian.apdvm.asso.fr
supermamie



Nombre de messages : 46
Date d'inscription : 11/09/2008

MessageSujet: Re: probleme avec la bestiole   Mar 23 Sep 2008, 20:19

Pour le coup tu n'a pas du beaucoup chercher ^^

http://www.l2jfree.com/index.php?topic=4654.0

Citation :
Downgrade to Subversion 1.4.5, and TortoiseSVN to the same if you using it.

Et si ça pose toujours probleme
http://www.l2jfree.com/index.php?topic=4654.15
Citation :

For those who, like me, still have problems, it could come from tortoise so try with the command line.

Code:
svn help
to be sure of the version

then
Code:
svn checkout "svn://l2jfree.com/repo/l2j-free/tags/Core Version 1.2.0"

Pense bien à mettre a jour ET ENSUITE récupérer les fichier du subversion.
Sinon tu aura récupéré avec la version que tu utilisais et c'est ça qui fait râler maven.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
decarvk



Nombre de messages : 242
Age : 27
Localisation : en france
Date d'inscription : 06/07/2008

MessageSujet: Re: probleme avec la bestiole   Mer 24 Sep 2008, 00:22

tu a raison je ne asse jamais sur le forum de l2j free je reste sur celui la quand j'ai besoin d'aide et pour mes partages, et je vais aider sur rpg paradize se qui fait deja trop ... de forum
enfin ici il y a des gens compétent qui pour ma mise au java et donc a la compilation peuvent m'aider et donc je m'appuies a 100% sur ce forum et les compétence des admin étant sur ce forum qui sont beaucoup moins "kikoulol" que sur rpg p, et qui eux peuvent m'aider, et je les en remercie.

comme certain diront tu peut apprendre de plus fort que toi si tu le souhaite il suffit de le vouloir et de demander au bonne personnes.


et ton poste le démontre j'ai mal cherche sur les autre forum, enfin sur rpg p et ici aucun solution n'était existante ^^

pour les downgrade du subversion je vais y regarder, merci supermamie.

car j'ai down maven j'usqua lla 2.0.0 sans résultats XD

enfin si j'arrive a compiler je m'atteler a mes premier script et donc premier modification qui seront bien entendu partager en rubrique technique.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://nemerian.apdvm.asso.fr
supermamie



Nombre de messages : 46
Date d'inscription : 11/09/2008

MessageSujet: Re: probleme avec la bestiole   Mer 24 Sep 2008, 01:42

En même temps j'ai répondu ça parce que j'ai eu exactement le même problème donc c'était facile de dire ça, je pense que j'aurais eu le même réflexe que toi Wink

(et oui je pense aussi qu'il est plus rapide d'apprendre quand on a des gens sur qui s'appuyer qu'en cherchant à l'aveuglette ^^ )
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: probleme avec la bestiole   Aujourd'hui à 01:23

Revenir en haut Aller en bas
 
probleme avec la bestiole
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» probleme avec les cellules d'excel sur la mise en forme
» Probleme avec connection en version mobile.
» Probleme avec le script de formulaire
» Probleme avec les images
» Probleme avec la gestion des codes javascript

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
L2J-FR :: Général :: Aides et Conseils-
Sauter vers: